Back
Maintenance

Upgrades

Completed 24 Jan at 01:00am CET.

Lehrmittel Assetverwaltung
Completed

Maintenance completed

Posted 24 Jan at 01:00am CET.
Started

Upgrades - System is down

Posted 23 Jan at 11:37pm CET.